Child pages
  • MAEviz development environment
Skip to end of metadata
Go to start of metadata

Setting up a MAEviz development environment

  1. Download Eclipse This should work with the latest version of Eclipse; however, it has been tested and verified with Eclipse Indigo which you can download here. Select the Eclipse for RCP and RAP developers download for your system specification.
  2. Install Eclipse Unpack Eclipse and launch the IDE.
  3. Get an SVN client for Eclipse Our source code is stored in Subversion, so you will need an SVN client. To install the subversion plug-ins, do the following:
    • Go to Help > Install New Software...
    • Where it says Work with: select Indigo - http://download.eclipse.org/releases/indigo
    • Expand Collaboration and select Subversive SVN Team Provider (Incubation) and go through the steps to install it. Restart Eclipse when it asks you to.
    • When Eclipse restarts, go to Window > Show View > Other. Expand SVN and select SVN Repositories and click OK. Choose the latest SVN Kit connector (1.30 as of 11/1/2010). Select an SVN Kit connector and click Finish. Go through the steps to install the SVN Kit connectors. Restart Eclipse when it asks you to.
  4. Connect to the MAEviz source repository Our repository is available read-only from svn://subversion.ncsa.uiuc.edu/ncsa-plugins/ or read-write if you have an account from svn+ssh://<username>@subversion.ncsa.uiuc.edu/CVS/ncsa-plugins/
  5. Checkout the plugins source To simplify the process of obtaining the latest MAEviz plug-ins we have created a team project set that will download all required plug-ins for MAEviz. To download the project set and import it, do the following:
    • Go to the MAEviz SVN Repository and expand Trunk. Find the plug-in called maeviz.team and check it out to your workspace
    • After the plug-in checks out, go to File > Import and expand Team and select Team Project Set. Click Next.
    • Click the Browse button and find the maeviz.team plugin. Go into that plug-in and you should see a file called maevizProjectSet.psf, select it. You should see a screen similar to the one below:
    • Click Finish and the MAEviz plug-ins will be checked out to your workspace automatically from subversion. Depending on the speed of your internet connection, this process could take some time.

When all plug-ins are checked out, you can improve the organization of your workspace by selecting Working Sets as your Top-Level Elements in Eclipse. This menu is located in the Package explorer menu (locate the inverted triangle in the Package explorer view), see the image below for the menu location.

To launch MAEviz, find the ncsa.maeviz.rcp plug-in and do the following:

  1. Open the file maeviz.feature.product by double clicking on it.
  2. In the Overview tab, locate the section labelled Testing and click Launch an Eclipse application.

MAEviz is developed using the Eclipse RCP platform and Java.  Understanding the APIs of these evironments, and how to use Eclipse for development, is outside the scope of this document.  Developers will need to be very familiar with Java programming and somewhat familiar with Eclipse RCP to be productive doing MAEviz development.

  • No labels