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Setup Cyberintegrator Development Environment
Overview
This document will help new developers setup their Eclipse development environment to get started working with Cyberintegrator and eAIRS.

Development Environment

The development environment will consist of Eclipse and some plug-ins we will need to add to the default installation (e.g. Maven for dependency 
management).

Software

In this section, we will outline

Installing Eclipse
Installing Graphical Editing Framework / Zest Library
Installing GWT
Adding Git repositories and Importing the projects from Git into a workspace
Updating Plug-in Classpath
Building spring-libraries project
Building eairs-cfd-tools project

Installing Eclipse:

First, download Eclipse Juno (4.2) . Download .here Eclipse for RCP and RAP Developers
Unzip the Eclipse download somewhere on your development machine, (e.g. )C:\Eclipse
Launch Eclipse. When Eclipse first launches, it will ask you to specify a workspace (e.g. ). After C:\Users(user-name)\workspaces\kisti
specifying a workspace, you can check the box "Use this as the default and do not ask again" box so that eclipse will not ask you to specify the 
workspace again.
After Eclipse loads for the first time, you will need to select the  button located on the middle of the welcome screen. The icon looks Workbench
like an arrow and when highlighted it will display some text that says .Go to the workbench

Installing Graphical Editing Framework / Zest Library

Next we need to install the Zest library that it used for displaying the workflow graphs. This will be downloaded and installed from the Eclipse 
Update Site. While in Eclipse, go to Help-> Install New Software. From the Drop down menu next to "Work with:" select Juno - http://download.
eclipse.org/releases/juno
Expand "Modeling" and select "Graphical Editing Framework Zest Visualization Toolkit SDK". Click Next. Click Next again. Accept the license 
agreement and click Finish. Once the installation finishes you will need to restart eclipse.
After restarting Eclipse, you might need to press the  button again to bring the workbench back up.Go to the workbench

Installing GWT

In order to build and run the Edison CFD web application you will need to download the latest GWT Eclipse plugin. The latest GWT Eclipse plugin can be 
found . Follow the instructions for your version of Eclipse.here

Adding Git repositories and Importing the projects from Git into a workspace

To obtain the source code for Cyberintegrator, PAW and Edison, there are 4 Git repositories that we will need to connect to. This section will describe how 
to check out each repository to your workspace.

http://eclipse.org/downloads/
http://download.eclipse.org/releases/juno
http://download.eclipse.org/releases/juno
https://developers.google.com/web-toolkit/download


1.  First, we will import ncsa-common.git. To do this, go to File > Import > Git > Projects from Git. Click Next.



2.  Select URI and click Next. See image below:
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5.  

Copy and Paste  into the URI field and it will auto-complete the rest. Click https://opensource.ncsa.illinois.edu/stash/scm/CBI/ncsa-common.git
Next. See image below:

Make sure master is checked and click Next. See image below:

It is suggested that you change the destination of the checked out project to be inside the workspace so in the future you could work with multiple 
versions in different workspaces. It keeps checked out projects more organized so you know the workspace that the project belongs to. If you 

https://opensource.ncsa.illinois.edu/stash/scm/CBI/ncsa-common.git
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created your workspace in the previous steps at  then we suggest you make the destination: C:\Users(user-name)\workspaces\kisti C:\Users
. See the image below for my settings. Everything else can be left as the default. Click Next.(user-name)\workspaces\kisti\git\ncsa-common

You can leave the defaults. Yours should look similar to the image below. Click Next.
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Make sure all projects are selected (similar to the image below) and click Finish.

After you checkout the first repository, your project may take some time to checkout Maven dependencies and attempt to build the workspace. Once this is 
finishes, you can proceed with the next repository. The only differences will be in step 3 (the repository URI) and in step 5 (where you put the repository 
projects).

The next repository to checkout is cyberintegrator.git. To check it out, go back to File > Import > Git > Projects from Git. Click Next.
Select URI and click Next.
Copy and Paste  into the URI field and it will auto-complete the rest. Click https://opensource.ncsa.illinois.edu/stash/scm/CBI/cyberintegrator.git
Next.
Make sure master is checked and click Next.
As with the previous project, we want to change the destination of the project to be inside the workspace. Make the destination for this repository 
as: . All other settings are the same as the previous step 5 image. Click Next.C:\Users(user-name)\workspaces\kisti\git\cyberintegrator
You can leave the defaults as they are. Click Next.
Make sure all projects are selected except for  and click Finish.dataset-rcp

As with the previous, this will take some time to checkout and build since it will begin downloading maven dependencies. Let this process finish and then 
move on to the final repository.

The last repository to checkout is paw.git. To check it out, go back to File > Import > Git > Projects from Git. Click Next.
Select URI and click Next.
Copy and Paste  into the URI field and it will auto-complete the rest. Click Next.https://opensource.ncsa.illinois.edu/stash/scm/CBI/paw.git
Make sure master is checked and click Next.
As with the previous project, we want to change the destination of the project to be inside the workspace. Make the destination for this repository 
as: . All other settings are the same as the previous step 5 image. Click Next.C:\Users(user-name)\workspaces\kisti\git\paw
You can leave the defaults as they are. Click Next.
Make sure all projects are selected and click Finish.

As with the previous two repositories, let the the workspace download it's maven dependencies and finish building before moving on to the next repository.

The last repository to checkout is edison-cfd.git. To check it out, go back to File > Import > Git > Projects from Git. Click Next.
Select URI and click Next.
Copy and Paste  into the URI field and it will auto-complete the rest. However, https://opensource.ncsa.illinois.edu/stash/scm/KNSG/edison-cfd.git
unlike the previous repositories, you will need to use your username/password for the repository. Enter that information and click Next.
Make sure master is checked and click Next.
As with the previous project, we want to change the destination of the project to be inside the workspace. Make the destination for this repository 
as: . All other settings are the same as the previous step 5 image. Click Next.C:\Users(user-name)\workspaces\kisti\git\edison-cfd
You can leave the defaults as they are. Click Next.
Make sure all projects are selected and click Finish.

As with the previous repositories, let the the workspace download it's maven dependencies and finish building before moving onto the next section. You 
can ignore any errors in the edison-cfd project since we are only interested in the eairs-cfd-tools.

Updating Plug-in Classpath

https://opensource.ncsa.illinois.edu/stash/scm/CBI/cyberintegrator.git
https://opensource.ncsa.illinois.edu/stash/scm/CBI/paw.git
https://opensource.ncsa.illinois.edu/stash/scm/KNSG/edison-cfd.git
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If you see an error in cyberintegrator-rcp ImportDatasetWizard.java saying that it cannot find the Logger class, you will need to fix the .classpath of the 
spring-libraries project. It is a known issue when combining Eclipse and Maven where both try to manage the classpath. To fix the issue, do the following:

Right click on spring-libraries and select Plug-in Tools > Update Classpath...

If you ever have to perform a Maven > Update Project or Run as > Maven Install on , then you will need to fix the classpath by performing spring-libraries
the action Plug-in Tools > Update Classpath.

Building spring-libraries project

The first time you check out the source code, you will need to build the  project. To do this, right click on it and select spring-libraries Run as > Maven 
. After doing this, if you have the error mentioned in the above section, perform the update classpath operation. If not, you can proceed to the next Install

section.

Building eairs-cfd-tools project

If this is the first time building everything, you will most likely first need to build two parent projects before we can build the eairs-cfd tools project. To 
determine if you need to build additional projects, do the following:

Right click on  and select eairs-cfd-tools Runs as > Maven Install

If it builds successfully, then you should see  in the console. However, if this it the first time building everything, you will most likely get Build Success
errors since you need to build the dependent projects. A convenient way to build everything is to build the parent  file that is in the top level of the pom.xml

 and  repositories. To build them, you will need to have Maven installed on your machine so you can run Maven ncsa-commom cyberintegrator
commands at the command line. To build those pom files at the command line, do the following:

Locate the directory where you checked out the  git repository (e.g. ). ncsa-common C:\Users(user-name)\workspaces\kisti\git\ncsa-common
Inside that directory, you should see a  file. To build the projects, run the command: .pom.xml mvn install
After that builds, locate the directory where you checked out the  git repository (e.g. cyberintegrator C:\Users(user-name)

). Inside that directory, you should also see  file. To build the projects, run the command: \workspaces\kisti\git\cyberintegrator pom.xml mvn 
.install

After that is finished, return to your Eclipse workspace and perform the action  on the  project and it should build Run as > Maven Install eairs-cfd-tools
properly.

This will put the jar files in your maven repository. If you are on Windows, then your maven repository will be in C:\Users\user-name\.
m2\respository\edu\illinois\ncsa. You should see a folder called eairs-cfd-tools that contains the jar we built. In the next section we'll discuss how to run 
Cyberintegrator and import those tools into your repository.

Running Cyberintegrator

This section will cover how to launch the Cyberintegrator application and import tools.

Running Cyberintegrator and Importing Tools

In this section, we will outline:

Launching Cyberintegrator
Importing eAIRS Java tools into Cyberintegrator
Importing eAIRS HPC Tool into Cyberintegrator
Build a New Workflow

Launching Cyberintegrator

To launch Cyberintegrator, do the following:

Expand the project cyberintegrator-rcp
Double click on Cyberintegrator.product to open the Product view
Under the  section, click the link Testing Launch an Eclipse Application

When Cyberintegrator finishes launching, you should see an image similar to the one below:



Importing eAIRS Java tools into Cyberintegrator

To import the Java tools we need, do the following:



1.  

2.  

Go to  and click Next.File > New > Other > Java Tool

Click the  button and find the following jar files in your  maven repository. Once you finish this, your wizard should look similar to the one Add .m2
below. Click Next.

eairs-cfd-tools.jar at C:\Users\user-name\.m2\repository\edu\illinois\ncsa\eairs-cfd-tools\0.0.1-SNAPSHOT
cyberintegrator-executor-hpc.jar at C:\Users\user-name\.m2\repository\edu\illinois\ncsa\cyberintegrator-executor-hpc\3.0.0-
SNAPSHOT
jsch-0.1.48.jar at C:\Users\user-name\.m2\repository\com\jcraft\jsch\0.1.48



2.  

slf4j-api-1.6.4.jar at C:\Users\user-name\.m2\repository\org\slf4j\sl4j-api\1.6.4
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You will see quite a few tools since some were created for testing. The Java tools we are interested in are EAIRSModelParameters, 
EAIRSFileTransfer and EairsCFDResult. Select them and click Finish. Your wizard should look similar to the one below before clicking Finish.

You should now see three new tools in your Tools View. To add them to the workspace, click and hold the mouse down and drag them to the Workflow 
Graph Builder. Currently, there is no remove option and the only way to remove a tool is to create a new workflow. To import the HPC tool, go to the next 
section.

Importing eAIRS HPC Tool into Cyberintegrator

To import the eAIRS hpc tool, do the following:

Go to  and click Next.File > New > Other > HPC Tool
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On this page, you can specify some basic information such as the name of the tool, the version and a brief description of what operation the tool 
performs. After doing this, click Next.

On this page, the primary fields are , , and . The executable is what we want to execute on the remote Executable HPC Template Options
machine.

In the case of eAIRS, we have a shell script, solver.sh, which takes in parameters to determine what to execute. Enter the complete path 
to the file on the remote machine in the text field. For example: */home/username/solver.sh*ssh
For , browse for the xml file that describes the machine that will be executing the tool.HPC Template
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For , there are two options we need to pass in. The first is a dataset describing the location of the staged files and the second is Options
a parameter (string) containing the name of the solver we want to execute. To add the dataset, click the  button and enter the Add Data
information seen in the image below to the dialog box that opens and click OK.

To add a parameter, click the  button and enter the information seen in the image below to the dialog box that opens and Add Parameter
Click OK when done.



4.  After entering the tool information, your wizard page should look similar to the image below. Click Finish to add the tool

You should now see a tool with the name you provided in the Tools view.

Building a New Workflow

This section will take you through the steps of building a new workflow using the eAIRS tools as an example. In order to run most of the workflow, you will 
need to create ssh keys and add them as trusted on the remote host. Before connecting the workflow steps, we will first add all 4 tools that are required: eA

, , , .IRS CFD Parameters eAIRS File-Transfer eAIRS-2D eAIRS Results

First, go to File > New > Workflow. In the dialog that opens, enter a title for the new workflow and click Finish.



This will clear any content that is in the  view and prepare it for building a new workflow. The first tool we will add is the Workflow Graph Builder eAIRS 
 tool.CFD Parameters

To add the  tool, left click with your mouse on it in the  view and while continuing to hold the mouse down, drag the eAIRS CFD Parameters Tools
tool onto the  view and drop it. When you drag the tool over the view, you should see a small plus symbol next to your Workflow Graph Builder
cursor that indicates you can add the tool. Your view should now look similar to the one below:



To add the  tool, follow the same procedure as the previous tool. This tool will stage the data to the remote machine for eAIRS File-Transfer
execution.
Next, add the  tool. This tool will execute the executable on the remote machine.eAIRS-2D
Finally, add the  tool. This tool will transfer the result files back to the Cyberintegrator repository.eAIRS Results

Your view should now look similar to the one below:

Next, we need to connect the tools together and specify any datasets that will come from external sources (e.g. a provided dataset not generated as an 
output from another Cyberintegrator tool).

First, we will connect  to  since we want it to stage the parameter file to the remote machine. To do eAIRS CFD Parameters eAIRS File-Transfer
this, right click on  and select . This should bring up a dialog box.eAIRS File-Transfer Connect > Tool Input

For the field , select Tool Input to Connect 0 - Model Parameter - (text/plain)
For the field  select Select Tool to Connect to eAIRS CFD Parameters
For the field  select . Your wizard should look similar to the one below. After doing Available Outputs 0 - Parameters.inp - (text/plain)
this, click .Finish



Next, we need to specify that the other input for , the mesh input, will be provided as an external dataset. To do this, right eAIRS File-Transfer
click on  and select .eAIRS File-Transfer Connect > Dataset
For the field , select . Click .Tool Input to Connect 1 - Mesh - (text/plain) Finish

The next tool we will connect is  to  since the CFD tool needs to know where the staged date is located. To do this, eAIRS File-Transfer eAIRS-2D
right click on  and select .eAIRS-2D Connect > Tool Input

For the field , select Tool Input to Connect 0 - File Locations - (text/plain)
For the field  select Select Tool to Connect to eAIRS File-Transfer
For the field  select . Your wizard should look similar to the one below. After doing Available Outputs 0 - file-locations.txt - (text/plain)
this, click .Finish



The last tool we will connect is  to  since the results tool will transfer the results of the analysis back to the eAIRS-2D eAIRS Results
Cyberintegrator Repository. To do this, right click on  and select .eAIRS Results Connect > Tool Input

For the field , select Tool Input to Connect 0 - HPC Log - (text/plain)
For the field  select Select Tool to Connect to eAIRS-2D
For the field  select . Your wizard should look similar to the one below. After doing this, Available Outputs 2 - gondola-log - (text/plain)
click .Finish



You  view should look similar to the one below:Workflow Graph Builder



To run the workflow, we need to open the  perspective and fill in any required parameters and dataset inputs. To switch to the  Execution Execution
perspective, go to .Window > Open Perspective > Other > Execution and click *OK

Once the view opens, click the ( ) icon to build the view. This will make sure the view is for the latest version of the workflow that is open. Your Refresh
workflow steps may appear in a different order (this is expected) so I will indicate the step name when filling in parameters.

For the  step, fill in the following parameterseAIRS CFD Parameters
Mach Number 0.75
Reynolds Number 100000.0
Angle of Attach 2.0
Error Tolerance 1.0E-5
CFL 3.0
Flow Type -1.0
Write File Interval 200.0
Total Iteration 10000.0
Steadiness 0.0
Flux Scheme 6.0
Limiter 4.0
Time Integration 3.0

For the  step, fill in the following parameterseAIRS File-Transfer
Username your username on the remote machine
Remote Path the location you want to stage the data on the remote machine
Target SSH the ssh URI for the remote machine, including port (e.g. ssh://ranger.tacc.teragrid.org:22)
For the  field, we will need to import a mesh. To do this, go to  and click . Browse for your mesh file Mesh File > Import > Dataset Next
and click . After adding your mesh dataset to the repository, click on the  button for the  field and select your Finish Browse... Mesh
dataset.

For the  step, fill in the following:eAIRS-2D
Solver Name The name of the solver you want to execute, (e.g. 2D_Comp-2.0)
Target Username your username on the remote machine
Target Userhome your home directory on the remote machine
Target SSH the ssh URI for the remote machine, including port (e.g. ssh://ranger.tacc.teragrid.org:22)

For the  step, fill in the following parameterseAIRS Results
Username your username on the remote machine
Target SSH the ssh URI for the remote machine, including port (e.g. ssh://ranger.tacc.teragrid.org:22)

After all that information is entered, click the  button to launch the workflow. Since the desktop User Interface is still in development, there Execute
currently is no indication of the workflow status in the Desktop client. You will need to check the console view of Eclipse to see when each step finishes. 
Shortly after the job has finished on the remote machine, the result dataset should transfer to the Cyberintegrator Desktop. However, because of a bug in 
the system, you will need to manually refresh the  view get the new dataset. This will be fixed shortly.Data
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