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Terminology

Project — Collection of Workflow. User defines the collection. Prefix: [P]; example: [P] 3D Surface Resonance’

Workflow — Collection of input files (model/mesh, parameter input file), pre-processor, solver, post-processor,
jobs, and output files with processing steps. Prefix: [W]; example: [W] WF1

Job — Unit of computation of Simulation sovler. 1 set of Model/mesh file and 1 set of parameter will be used to
execute. Job also contains the concept of the term, “case”
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01 Home page - Login

Ul

Home H My EDISON ” Project ” Contents || Community ” Class ” Support " About || Site map

EDISON Account

Account name
/ EEEEE |
OJ.

Login S}X| €
AL8AHES
7150 2¥

e Password
} [H2E o |

[ LOGIN J [ REGISTER J

E D I S Forgot your id/password?
-

Scenario

® Prerequisite condition
W C1: Selected My EDISON Tab menu
B C2: Clicked Login button

® QOutcome
B Move to [03 My EDISON] page

® Scenario
m S1
@ Enter ID and PW
@ Press Enter Key or Click Login button

m El

& Display Error message for wrong ID/PW
m Al

@ Click ‘Forgot your id/password?’ link = Display “finding id/password” page
m A2

@ Click REGISTER button - Display “registration” page
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02 My EDISON
Ul
Vg " Projects
David J. Lim LOGOUT New Project
(david,j.lim@kisti.re.kr) ——  more .. % N o \
My Projects EDISON News
Profile / Information
» Org: KISTI 2D Fast Flow = =

» New msgs: 5 3D Severe Pressure

» Another item... 3D Turbulence Crack

o

» More... 2D Big Swing

( ™

My Tools Community News

B C-CFD HRLE| B
- [TOOL] Turbo Transformer — 2011-02-14
B cFD020

[l [Lab] 8 +YS% - 2011-02-15

: ®

~ > 3
M L L L L d T e e e e L L L L L L L L L L L L D L L T g

e ——

N

Scenario

® Prerequisite condition
B C1: Already logged in

® Outcome
B Move to [03 New Project] page

® Scenario
m S1
@ Open Project Tab> menu by hover over ‘Project Tab’
@ Select ‘New Project” on pop-up menu
m S2
@ Click on ‘Project Tab’ or Select ‘Projects’ on pop-up menu
€ Move to [03-A Projects] page that shows the list of projects

¥ (D: Navigation area
¥ (@: Main window area
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03 New Project

Ul

Home ” My EDISON H Project H Contents H Community ” Class ” Support ” About H Site map ‘

David J. Lim LOGOUT Project : [P] New Project
(david,j.lim@kisti.re.kr)

_]_[P] New Project k Enter the title of new project
@W] New Workflow Project Title:
B ‘ TiP1 New Project
53]
@

e |
E

HOK{$

Workflow Definition = Preprocessing - Simulation - Postprocessing

Scenario

® Prerequisite condition
B C1: Select ‘New Project’ on pop-up menu from [02 My EDISON] page
B C2: Click on ‘New Project’ on [A Project] page which haven’t developed yet
B C3: Generate empty ‘[P] New Project’ and empty ‘[W] New Workflow’. Model, Preprocess, Simulation
Tool, and Postprocess under Info are inactive. Jobs item also is inactive

® QOutcome
B Make Project Name, ‘[P] 3D Surface Resonance’, with prefix ‘[P]” and user’s input
B Move to [04 New Workflow] page

® Scenario
m S1
@ Click on *[P] New Project’
@ Enter ‘3D Surface Resonance’ as new project name then press Enter key or click on ‘OK” button
m S2
@ Clickon @ text box
@ Enter ‘3D Surface Resonance’ as new project name then press Enter key or click on ‘OK” button
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03-A Projects — Project LIST

Ul

Scenario

Prerequisite Condition

Outcome

Scenario

[ TO BE DESIGNED ] ...
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04 New Workflow

UI

Project [ Contents | Community || Class | support || About [ site map |

Project : [P] 3D Surface Resonan

David J. Lim LOGOUT
(david j.lim@kisti.re.kr)
[Project Information] — [[P] 3D Surface Resonance]

[E 3D Surface Resonance
» Create new workflow?
Bl W New Workﬂm@

El Info
B Model
@ Preprocess
B Ssimulation Too
B Postprocess
B Jobs

Workflow Definition = Preprocessing > Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Crated new project called ‘[P] 3D Surface Resonance’

® Qutcome
B N1: S1 > move to [04-1 New Workflow — Enter workflow title] page
B N2: S2 > move to [04-2 New Workflow — [W] WF1 created] page
B N3: *S2 - move to [05 WFD Method] page
B User can select either * N2 or N3

® Scenario
m S1

@ Click on ‘New Workflow’ button (D) > N1
m S2

@ Click on ‘[W] New Workflow’ item ()
@ Enter “WF1’ as new workflow name then press Enter key - N2 [or N3]
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04-1 New Workflow — Enter workflow title

UI

David J. Lim LOGOUT W" : [P] 3D Surface Resonan >erﬂiw-I Hi Niwwirkﬂiw

(david.j.lim@kisti.re.kr)

3D Surface Resonance Enter the title of new workflow

Bl W New Workflo\% Workflow Title:
E mfo

B Model

@ Preprocess

B Ssimulation Too

B Postprocess
B Jobs

’ I[W] New Workflow ‘ [ OK%

Workflow Definition = Preprocessing > Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Clicked on ‘New workflow’ button on [04] page (or Workflow list page such as [04-2], [04-3])

® Qutcome
B N1: Set ‘[W] WF1’ as workflow name and Move to [04-2 New Workflow — [W] WF1 created] page
B N2: Move to * or [05 WFD Method] page
B User can select either Nlor N2

@® Scenario
m S1
@ Enter ‘WF1’ in the text box, ‘Workflow Title’
@ Press Enter key or Click on ‘OK’ button - N1 [or N2]
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04-2 New Workflow — [W] WF1 created
)
Home ” My EDISON H Project ’ Contents H Community ” Class ” Support ” About H Site map ‘
David J. Lim LOGOUT Project : [P] 3D Surface Resonance

(david,j.lim@kisti.re.kr)

[=] [P] 3D Surface Re:
B w violin
£
=

[Project Information] — [[P] 3D Surface Resonance]

sonance
» Create New Workflow?
+ vl

Bl Wi New Workﬂov%

Workflow Definition = Preprocessing - Simulation - Postprocessing

Scenario

® Prerequisite Condition
B C1: Created empty ‘[W] WF1’
B C2: Selected ‘[P] 3D Surface Resonance’ project

® Outcome
B N1:S1->
B N2:S2 >
B N3:S3->

® Scenario
m S1

Move to [05 Choosing Workflow Definition Method - WFD Method] page
Move to [04-2] or [04-3]
Move to [04-1 New Workflow - Enter workflow title]

@ Click ‘Edit’ button at ‘[W] WF1’ project on main window area > N1

m S2

@ Create another new workflow on navigation area> N2

m S3
@ Creat

e another new workflow by click on ‘New Workflow’ button on main window area > N3

- 10 -
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04-3 New Workflow - Add
Ul
Home ” My EDISON ‘ Project | Contents H Community ” Class ” Support ” About H Site map ‘
David J. Lim LOGOUT Project : [P] 3D Surface Resonance

(david,j.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

» Create New Workflow?
Bl wi violin
B (w) Bass Drum » [W] Violin
B W Trumpet -

Bl Wi New wwow

[Project Information] — [[P] 3D Surface Resonance]

» [W] Bass Drum

» [W] Trumpet

Workflow Definition > Preprocessing > Simulation > Postprocessing

Scenario

® Prerequisite Condition

B C1: There are many workflows under a project
B C2: Selected ‘[P] 3D Surface Resonance’

® Outcome

B N1:S1 - Move to [05 WFD Method]

B N2: Execute appropriate functions depending on empty workflow, workflow with detail info (steps
defined), and workflow with jobs

B N3: S3 > Move to [04-2] or [04-3]

B N4: S4 > Move to [04-1 New Workflow - Enter workflow title]

® Scenario

m S1
@ Click ‘Edit’ button of ‘[W] WF1’ > N1
m S2
@ Click ‘Edit’ on other workflow > N2
m S3
@ Create another new workflow on navigation area> N2
m S4
& Create another new workflow by click on ‘New Workflow” button on main window area - N3

- 11 -
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05 Choosing Workflow Definition Method — WFD Method

Ul

Home ” My EDISON ‘ Contents H Community ” Class ” Support ” About H Site map ‘

Project

David J le LOGOUT Project : [P] 3D Surface Resonance > Workflow : [W] Proj Violin

(david,j.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

B w violin Choose how to define workflow :
E info Choose the input (model) file(s) first
& Choose the tool first
Use a existing workflow
& |
&

E [W] Bass Drum
Info
Jobs

B wi Trumpet
Info
Jobs

Workflow Definition > Preprocessing - Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1:Clicked ‘Edit’ button of ‘[W] WF1’ at [04-2] or [04-3] page
B C2: * Created new empty workflow

® Outcome
B N1: Move to [06 How to Set Input File - WFD Input File]
B N2: Move to [06-A Select tool first for workflow] (not yet)
B N3: Move to [06-7 Select existing workflow] (not yet)

® Scenario
m S1
@ Select the item, ‘Choose the input (model) file(s) first’, then click ‘Next’ button > N1
m S2
@ Select the item, ‘Choose the tool first’, then click ‘Next’ button 2> N2
m S3
@ Select the item, ‘Use an existing workflow’, then click ‘Next” button > N3
H El
@ If a user clicked other menus or buttons, then the current workflow info will be lost

-12 -
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06 How to Set Input File — WFD Input File

)

Home | My EDISON | Project

| Contents || Community ” Class ” Support " About || Site map

David J. Lim LOGOUT Project : [P] 3D Surface Resonance > Workflow : [W] Proj Violin

(davidj.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

B w violin Choose how to set input (model) file(s) :
E info Upload input (model) file(s) from your computer
® Create new input (model) file(s)
Use existing input (model) file(s) stored in server
2 b |
53]
[ <- Back ] [ Next -> ]
B  (w) Bass Drum
E info
Jobs
E [W] Trumpet
Info
Jobs

Workflow Definition = Preprocessing = Simulation = Postprocessing

Scenario

® Prerequisite Condition
B Cl:Selected ‘Choose the input (model) file(s) first’

® Outcome
B N1:S1 - Move to [07 Choosing Preproc-Tool-Postproc - WFD Pre-Tool-Post]
B N2:S2 - Move to [07-A Upload Input (Model) Files] (to be designed)
B N3: S3 2> Move to [07-B Choosing Existing Input (Model) Files] (to be designed)

® Scenario
m Sl

@ Select the item, ‘Create new input (model) file(s)’, then click ‘Next” button > N1
m S2

@ Select the item, ‘Upload input (model) file(s) from your computer’, then click ‘Next” button = N2

m S3

@ Select the item, ‘Use existing input (model) files(s) stored in server’, then click ‘Next’ button >

N3

- 13 -
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07 Choosing Preproc-Tool-Postproc - WFD Pre-Tool-Post
Ul
Home ” My EDISON H Project H Contents || Community ” Class ” Support " About || Site map |
David J. Lim LOGOUT Project : [P] 3D Surface Resonance > Workflow : [W] Proj Violin
(davidj.lim@kisti.re.kr)
1. Choose type of the problem : ~N
= [P] 3D Surface Resonance [ Vv 2D Structured solver Compressible flow }
V| 3D L V| Unstructured solver Incompressible flow
E [W] Violin
E nfo [ V] Viscous flow V| Laminar
3l L V| Inviscid flow V| Turbulence
- - E ol ‘ @
V| Steady HAE 2 T
U g v k-w SST
L nsteady LES
2 | DES
23] DNS
N
— 2. Choose preprocessor-solver-postprocessor :
Bl W Bass Drum Preprocessor : | preprocessor list  [v
E Solver : [ simulation tool list [+] &2
Jobs Postprocessor : ‘ postprocessor list [v
E [W] Trumpet N
Info [ <- Back ] [ Next -> ]
Jobs
Workflow Definition = Preprocessing = Simulation = Postprocessing

Scenario

® Prerequisite Condition

B C1: Selected ‘Create new input (model) files” at [06 How to Set Input Files] page
® Outcome

B N1: Move to [08 Workflow Review — WFD Review]

® Scenario
m S1
@ Select items at ‘1. Choose type of the problem’
@ Then, the items at 2. Choose preprocessor-solver-postprocessor:” will be generated
@ Select preprocessor, solver, postprocessor then click ‘Next’ button

user selected in a group (AND operation) and those items are not selected in a group will be ignored in the search.

W Exl: ‘2D’ and ‘3D’ are selected - the solvers that can solve both ‘2D’ and ‘3D’ are displayed.

[ ]
“Unstructured’ problem are displayed

[ ]
criteria

Turbulence & k-w SST)

> ‘1. Choose type ...” When user selected multiple items in a group, then system looks for solver to satisfy all the items

Ex2: ‘Structured solver’ is not selected and ‘Unstructured solver’ is selected - the solvers that can solve
Ex3: Neither ‘Compressible flow’ nor ‘Incompressible flow’ are selected - the search does not care about this

Picture above: (2D & 3D) & (Unstructured) & ( [don’t-care] ) & (Viscous & Inviscid & Steady) & (Laminar &

- 14 -
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08 Workflow Review — WFD Review

)

Project [ Contents || Community [~ Class [ Suppore | About |['site map |

David J. Lim LOGOUT Pro'lect: P] 3D Surface Resonance > Workﬂow:lg Pro'l Violin
(davidj.lim@kisti.re.kr)
Workflow Definition Review
[=] [P] 3D Surface Resonance
g wover ~ Preprocessing m
iolin -|t
Info: ABC Pre @
El Info L )
B Model ~ Solver )
Edit
@ Preprocess Info: QuickSol @ ;]
E Simulation Tool <
B Postprocess
E Jobs \ J
Bl Wi Bass brum ~ Preprocessing N
@ o Info: CoolVis
\
E Jobs
[FE Info
E Jobs
Workflow Definition > Preprocessing = Simulation = Postprocessing

Scenario

® Prerequisite Condition
B C1: Defined preprocessor, solver, and postprocessor for ‘\[W] WF1’ Workflow

® QOutcome
H N1
@ Enable items, Pre, Sim, Post, at Navigation area
€ Move to [09 Creating Model/Mesh — Pre-Dummy]
B N2: Move to [07 Choosing Preproc-Tool-Postproc — WFD Pre-Tool-Post] or [08-A Workflow edit] ( to

be designed)

® Scenario

m Sl
@ Click “Next” button > N1

m S2
@ Click ‘Edit’ button to modify > N2

m S3
@ Click ‘Save’ button - workflow info will be store on local/remote storage temporally (it will

make user be able to work later)

- 15 -
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09 Creating Model/Mesh — Pre-Dummy

)

Project [ Contents || Community [~ Class [ Suppore | About |['site map |
105 —

David J. Lim LOGOUT
(davidj.lim@kisti.re.kr)

[= [P] 3D Surface Resonance - Creating Model/Mesh — [Preprocessor FAST Creator] : h
B i violin [ Type model title here... |
= 1;’ o Shape : | Simple shape 1 ™
B Preprocess X Size :
B simulation Tool | Y Size :
- T}\ Postprocess Z Size :
Bl Wi Bass Drum ‘ ‘ m
B o ) /

@

B wi Trumpet
[FE Info
E Jobs

Workflow Definition > Preprocessing > Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Clicked ‘Next’ button at [08 Workflow Review — WFD Review] page
B C2:== 3|3 workflow FH =H]

® Outcome
B N1: Store generated Model and Mesh file at the server
B N2: Move to [10 Choosing Single/Multiple Param Set]

® Scenario
m S1
@ Enter information at each item, then click ‘Next’ button = N1, N2

- 16 -
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10 Choosing Single/Multiple Param Set

)

David J. Lim LOGOUT M : ii iiii'i'ii i iﬁiiiiil mi ii | |

(davidj.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

B w violin Choose parameter set type :
E mfo .
©) Add single set of parameters
E Model

O) Add_multiple sets of parameters
m Preprocess

[# Simulation Tool

'

[ Postprocess
B Jobs
B  (w) Bass Drum
E info
E Jobs
B wi Trumpet
[FE Info
E Jobs

Workflow Definition = Preprocessing - Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Defined all information for the workflow

® QOutcome
B N1: S1 > Move to [11 Single Parameter Set - Sim-Param Single]
B N2: S2 > Move to [12 Multiple Parameter Set — Sim-Param Multi]

® Scenario
m S1
@ Select the first item then click ‘Next’ button = N1
m S2
@ Select the second item then click ‘Next’ button = N2

-17 -
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11 Single Parameter Set — Sim-Param Single

)

Project | Contents || Community || Class [ support | About [ site map |
Pro'lect: P] 3D Surface Resonance > Workflow : |H Violin > Jobs

David J. Lim LOGOUT
(davidj.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

B w violin Single set of parameters :
= nfo Parameters Values
B Model - Parameter 1 :
[ Preprocess - Parameter 2 :
[# Simulation Tool - Parameter 3: (©) Option1 (O) Option 2

[ Postprocess
E Jobs [ More S.Job... ] [ More M.Job... ]
B  (w) Bass Drum

E info
E Jobs
B wi Trumpet
[FE Info
E Jobs

Workflow Definition = Preprocessing - Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Selected ‘Add single set of parameters’

® QOutcome
B N1: S1 > Move to [14 Jobs/Parameter Review - Pre-Param Review]
B N2: S2 > Move to [11 Sim-Param Single]
B N3: S3 > Move to [12 Sim-Param Multi]

® Scenario
m S1
@ Enter all parameters then click ‘Next” button > N1
m S2
@ Enter all parameters then click ‘More S.Job...” button > N2
m S3
@ Enter all parameters then click ‘More M.Job...” button = N3

-18 -
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12 Multiple Parameter Set — Sim-Param Multi

)

Project | Contents || Community || Class [ support | About [ site map |
Pro'lect: i 3D Surface Resonance > Workflow : H Proj Violin > Jobs

David J. Lim LOGOUT
(davidj.lim@kisti.re.kr)

[=] [P] 3D Surface Resonance

B w violin Multiple sets of parameters :
= info Parameters From To Step
[ Model - Parameter 1: [ 100 | [ 200 | [ 10 |
[ Preprocess - Parameter 2 : | 80 | [ 100 | [4 |
[# Simulation Tool - Parameter 3: (©) Option1 (O) Option 2 o) All

[ Postprocess
B Joos [ More S.Job... ] [ More M.Job... ]
E [W] Bass Drum

E info
E Jobs
B wi Trumpet
[FE Info
E Jobs

Workflow Definition = Preprocessing - Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Selected ‘Add multiple sets of parameters’

® QOutcome
B N1: S1 > Move to [13 Jobs/Parameter Review - Pre-Param Review]
B N2: S2 > Move to [11 Sim-Param Single]
B N3: S3 > Move to [12 Sim-Param Multi]

® Scenario
m S1
@ Enter all parameters then click ‘Next” button > N1
m S2
@ Enter all parameters then click ‘More S.Job...” button > N2
m S3
@ Enter all parameters then click ‘More M.Job...” button = N3

-19 -
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13 Jobs/Parameter Review — Sim-Param Review

)

Home |['My EDISON | Project

’ Contents H Community ” Class ” Support ” About H Site map ‘

David J. Lim LOGOUT Project : [p] 3D Surface Resonance > Workflow : [W] Proj Violin > Jobs

(david,j.lim@kisti.re.kr)

Review Simulation Jobs

[=] [P] 3D Surface Resonance SJob 1 :
Parameters Values @

B w violin
- Parameter 1 :

E mfo
- Parameter 2 :

HE Model

breprocess - Parameter 3 : Option 1 Option 2
£

£

Simulation Tool S.Job 2 -
h ( Parameters Values @) Edit...

Postprocess

M.Job 3 ... :
Parameters From To Step @

E [W] Bass Drum

- Parameter 1: [ 100 | [ 200 | [ 20 |
E Inf
& no - Parameter 2 : [ 80 | [ 100 | [ 4 |
Jobs
- Parameter 3 : Option 1 Option 2 All
E [W] Trumpet
FE info J
o [ More S.Job... ] [ More M.Job... ] [ Save ] [ Submit > ]
obs

Workflow Definition = Preprocessing > Simulation - Postprocessing

Scenario

® Prerequisite Condition
B C1: Defined all information about workflow and parameters

® Outcome
B N1: S1 - Submit all jobs and Move to [14 Simulation Monitoring]
B N2: S2 - Move to [11 Sim-Param Single], S3 > Move to [12 Sim-Param Multi]
B N3: For S.Job, move to [13-A Single Param Edit] (to be designed),
For M.Job, move to [13-B Multi Param Edit] (to be designed)
B N4: S4 > Store workflow info and set of parameters on local/remote server

® Scenario
m S1
@ Click ‘Submit’ button > N1
m S2
@ Click ‘More S.Job...” button or ‘More M.Job...” button - N2
m S3
@ Click ‘Edit’ on jobs to modify > N3
H S4
@ Click ‘Save’ button to store current state > N4

- 20 -
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14 Simulation Monitoring

UI

Project [ Contents | Community || Class | support || About [ site map |

David J. Lim  Locour | Froeets(pl30 Suracs Resonence s oo sMPoIMiomm 2o
(david j.lim@kisti.re.kr)
» Job Monitoring N
[=] [P] 3D Surface Resonance
B W) violn Jobs Status Download
E mnfo | SJob 1 | Done v
B Model m SJob 2 — Running 7
I W Mlob 3. —— - Lof4 —@ v
[# Simulation Tool y - MJob 3-1 | Done ¥/
H  Postprocess - MJob 3-2 r— | Running v/
[ Jobs - MJob 3-3 [F— Running v
E [W] Bass Drum - MJob 3-3 — Running v/
E info
_
Jobs
N
E [W] Trumpet J
[FE Info
E Jobs

Workflow Definition = Preprocessing - Simulation > Postprocessing

Scenario

® Prerequisite Condition
B C1: Submitted jobs of ‘[W] WF1’

® Outcome
B N1: S1 > Move to [15 Postprocessing — Visualization]
B N2: S2 > Move to [15-A Downloading Result] (to be designed)

@® Scenario
m S1
@ Check ‘Status’ of the jobs
@ For Multiple job (M.Job), the panel is collapsible
@ Click “Visualize’ button for a job finished (‘DONE’) > N1
m S2
@ Check ‘Download’ for finished jobs
@ Click ‘Download’ button > N2

-21 -
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15 Postprocessing — Visualization

UI

Project

David J. Lim LOGOUT
(david,j.lim@kisti.re.kr)

~ Postprocessor — CoolVis - [ MJob 3-1]
[=] [P] 3D Surface Resonance

B w violin
E mfo
HE Model
[ Preprocess
[# Simulation Tool
[ Postprocess
E Jobs
B  (w) Bass Drum
E info
E Jobs
B wi Trumpet
[FE Info
E Jobs

Workflow Definition > Preprocessing - Simulation - Postprocessing

Scenario

® Prerequisite Condition
B C1:Job, M.Job 3-1, has been done

® Outcome
B N1: Move to [14 Simulation Monitoring]
B N2: * or Move to [15-B Job List] (to be designed)

® Scenario
H S1
@ Visualize the result with ‘CoolVis’
@ Click ‘Close’ > N1 [or N2]
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